Topic: Interface language

in 4.7.0 version I have set Italian language, but when I login with my user, the interface is in english.

I have set "Italian" in "settings" and in "Users".

The "Public Access" is correct in Italian, but when I login as user, it return to English.

This is a fresh install, no upgrade.

Thank you in advance

Re: Interface language

Hi Luigi,
There could be two reasons:
1. You have selected maybe via the Options Panel the English language and this is saved in a PHP session variable. During the PHP session, the calendar will take the language from this PHP session variable, unless you select an other language. PHP sessions last normally no longer than 22 minutes (of calendar inactivity), so this problem should solve itself when you close the calendar for more than 22 minutes.
2. On the Settings page, under User Accounts you have checked "Restore last user selections" and you have once selected English, which was subsequently stored in a cookie. If you log out now and log in again, it will take the last user selections, i.e. English. To overrule this, take care that on the Settings page, under User Accounts, "Restore last user selections" is checked and in the Options Panel select the Italian language. Now the last selections, including the Italian language will be stored in a cookie. Now the problem should be solved.


Re: Interface language

Hi Roel,
it seems solved with cleaning of IE cache and temporary files. Probably was an issue of PHP session variable.
Thank you for support.