RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Problems / Time Format - 24 hour
Posted:  05 Dec 2012 04:16
Hello:
I am trying to set the time to true 24hrs.  This means that 9:00 is 09:00 and actually displays it properly with the "leading" zero.  I have tried setting it in the settings, but I think that this might be embedded deeper in the .js file, which if it is, might as well be in Chinese.  Is there an easy fix to this?

Thanks,
Posted:  05 Dec 2012 11:03   Last Edited By: Roel B.
Hi there,
Yes, there is an easy fix. Not in Chinese, but in Japanese, if that's ok with you wink

In the file common/toolbox.php on line 25 replace 'g' and 'G' by 'h' and 'H' respectively. So this line should look as follows:

    $phpFormat = str_replace(array('h','m'),array(($ampm ? 'h' : 'H'),'i'),$format);

I've added the option to specify hours with leading zeros to the admin's Settings page, so this option will be available iin the next LuxCal release.
Roel
Posted:  07 Dec 2012 02:17
Once again, thanks sooo much !!!