RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Problems / Problem with NEW install
Posted:  30 Aug 2012 15:58   Last Edited By: webadmin
I just installed Luxcal 2.7.0 and got the PUBLIC VIEW working just fine. I then logged in to the admin area and tried to add an event and when I clicked on the day to add the event I got this message and I can no longer see/use the calendar. Also, mini calendar is still viewable on different page.

Any ideas ?

not permitted (index: luxcal=a:2:{i:0;s:1:"2";i:1;N;})
Posted:  30 Aug 2012 18:33
Ok,

I found this error code (of sorts) in the PHP VARIABLES section of the .phpinfo.php file. What do I need to do to stop this from happening ?


http://www.jsbwebs.com/ss2013/luxcal270/Untitled-1.jpg
Posted:  30 Aug 2012 19:40   Last Edited By: Roel B.
The luxcal and lctest variables are normal variables, not error codes. The other variables are not LuxCal.

The problem in your first post is a known problem and will be fixed in the next LuxCal sub-release which will be issued in the coming days.
You can easily solve this problem by editing the file common/toolbox.php and change line 148 as follows:
Change from
case 'luxcal': return preg_match('%^a:2:{.{20,60};}$%', trim($value)) ? true : false;
into
case 'luxcal': return preg_match('%^a:2:{.{15,60};}$%', trim($value)) ? true : false;
In short: in the middle of this line replace "20" by "15". Use a "plain text" editor.
Roel
Posted:  30 Aug 2012 21:21
Thanks Roel,

That did the trick !    thump_up  :D