RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Support / Unable to install
Posted:  07 Oct 2017 13:27   Last Edited By: Roel B.
I am trying to install SQLite. I upload files under the default directory /luxcal452L-calendar (leaving the same as the download) and cannot start the installation. When I go to www.websitename/luxcal452L-calendar I get the following message in my browser.
Can anyone tell me what this message means?
Thankssad


Warning: session_start(): open(/storage/ssd4/884/1598884/tmp/sess_43lat67adoh4v2v9coolgvfnbf, O_RDWR) failed: No such file or directory (2) in /storage/ssd4/884/1598884/public_html/luxcal452L-calendar/index.php on line 64

Warning: session_start(): Failed to read session data: files (path: /storage/ssd4/884/1598884/tmp) in /storage/ssd4/884/1598884/public_html/luxcal452L-calendar/index.php on line 64

Warning: Cannot modify header information - headers already sent by (output started at /storage/ssd4/884/1598884/public_html/luxcal452L-calendar/index.php:64) in /storage/ssd4/884/1598884/public_html/luxcal452L-calendar/index.php on line 78
Posted:  08 Oct 2017 20:48   Last Edited By: Roel B.
Hi Keith,

Could you please tell us if this is the first time you (try to) install LuxCal on this server?
I have the impression that the PHP sessions are not working due to a problem in the PHP installation.

Note: the last two error messages are a result of the first error, so we should concentrate on the first error.

Once I know if this is the first time installation, I will try to help you solve the problem.
Roel
Posted:  09 Oct 2017 12:43
Hello Roel,
Thanks for the reply - yes this is the first time I have tried to install LuxCal -
I did get through to the 'install452.php' page once and entered the options and pressed 'Test' and it seemed to work OK
I then changed the name of the db directory and tried 'Test' again and then got the error message. I don't know if this is significant or not.
I never actually pressed 'Install' so no installation has taken place.
Now whatever I change and no mater how many times I try (over three days) I still get the same message.
If I run 'install452.php' directly I get the error message printed over the top of the install page and if I fill in the options and press 'Test' I get these messages -

Tests failed:
    PHP sessions not working
    Check PHP installation on your server
 
Tests passed:
    PHP version 7.1.7 Ok
    PHP PDO-SQLite extension Ok
    Writing to the database folder 'db/'
    Writing to the calendar's root folder
    Writing to the 'files' folder
    Writing an empty sql.log file to the 'logs' folder
    Writing an empty luxcal.log file to the 'logs' folder

----------------------------------------------------------------------------------   
This seems to say sessions not working but I have tried this php file -

<?php
session_start();
session_destroy();
session_start();
$_SESSION["user"] = "Keith";
echo $_SESSION["user"];
phpinfo();
?>

and it echos back 'Keith'
and the following info (see next post)

PHP Version 7.1.7
(under session section)
session
Session Support     enabled
Registered save handlers     files user
Registered serializer handlers     php_serialize php php_binary wddx
Directive    Local Value    Master Value
session.auto_start    Off    Off
session.cache_expire    180    180
session.cache_limiter    nocache    nocache
session.cookie_domain    no value    no value
session.cookie_httponly    Off    Off
session.cookie_lifetime    0    0
session.cookie_path    /    /
session.cookie_secure    Off    Off
session.gc_divisor    1000    1000
session.gc_maxlifetime    1440    1440
session.gc_probability    1    1
session.lazy_write    On    On
session.name    PHPSESSID    PHPSESSID
session.referer_check    no value    no value
session.save_handler    files    files
session.save_path    /storage/ssd4/884/1598884/tmp    no value
session.serialize_handler    php    php
session.sid_bits_per_character    5    5
session.sid_length    26    26
session.upload_progress.cleanup    On    On
session.upload_progress.enabled    On    On
session.upload_progress.freq    1%    1%
session.upload_progress.min_freq    1    1
session.upload_progress.name    PHP_SESSION_UPLOAD_PROGRESS    PHP_SESSION_UPLOAD_PROGRESS
session.upload_progress.prefix    upload_progress_    upload_progress_
session.use_cookies    On    On
session.use_only_cookies    On    On
session.use_strict_mode    Off    Off
session.use_trans_sid    0    0

HOPE THIS HELPS!
( I only partly know what I am doing - from reading stuff)!!!

Thanks for your help
Posted:  09 Oct 2017 23:07   Last Edited By: Roel B.
Hello Keith,
Just a couple of considerations:
- You said that before you changed the db directory "it seemed to work OK". However, in your first post's error message it appeared that sessions were not working and after you changed the db directory, again sessions were not working. I don't understand this (that it seemed to work OK), because there is absolutely no relation between sessions and the db directory.

- You ran the PHP script to test sessions, but in the same script you set 'user' and you echoed 'user':
$_SESSION["user"] = "Keith";
echo $_SESSION["user"];

But what you should do is first run your script and then (within 20 minutes) run the following script . . .
<?php
session_start();
echo $_SESSION["user"];
?>

. . . and see if it still echoes "Keith". If so, PHP sessions are working.

I think they are not working, and if I'm right, it's almost certainly the "session.save_path" which is wrongly defined (path not existing in your first post). I've seen this problem many times. The session.save_path is normally set to "/tmp".
Could you change the session.save_path in the php.ini file?

Roel
Posted:  10 Oct 2017 12:34   Last Edited By: Roel B.
Hi Roel,
1)  I first ran 'Test' using ../db as the db directory - I did not notice any errors
(db was created in my root html directory /public_html along with my other html files)

2)  I then realised I should have tried ../../db (to see if I could create it in / /puiblic_html) so I ran 'Test' again I then noticed errors
(db was successfully created in / /public_html above my html files directory)

3) Also I originally had the files in /public_html/luxcal and I changed the name back to /public_html/luxcal452L-calendar to see if that would work

3) I tried 
<?php
session_start();
echo $_SESSION["user"];
?>
straight away and again after a few minutes and I got nothing, a blank page!

4) I cannot edit the php.ini file, I am using free hosting at 000webhost and they do not alow access to php.ini

I could give you access to the site if that would help!

Keith
Posted:  18 Oct 2017 11:56
I have managed to fix this problem! - it appears that my 000webhost directory structure was not setup correctly by them. The usual /tmp directory did not exist. I was able to get access to the level above /public_html and create it, then everything worked - simples!thump_up