LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Support / Issues sending email with SMTP Server
Posted:  15 Mar 2017 13:13
I have just configured SMTP to use office 365 and unable to send test mail using LuxCal.

I have enabled SSL and the port is 587, along with username and password. The same setting is working with other applications, but not on this.

Please can you advise?

Posted:  15 Mar 2017 14:46   Last Edited By: Danwestlake
Hello Sri,

Do you have the server as Check the spelling if that is what you have.

I know some servers have the user name others have the email address. Since I don't use Office365 I don't know what they require.

What is the error you get if you get an error?

"Little Guy"
Some own motorcycles, others ride them.

Find great LuxCal examples by Schwartz at
Posted:  15 Mar 2017 14:54
Hi Dan,

Yes, server name is
port is 587
SSL is checked
SMTP authentication is checked (I have provided email id and password)

Error is as below:

Warning: fsockopen() [function.fsockopen]: SSL operation failed with code 1. OpenSSL Error messages: error:140770FC:SSL routines:func(119):reason(252) in /home/gbsrsb5/public_html/book/common/messaging.php on line 138

Warning: fsockopen() [function.fsockopen]: Failed to enable crypto in /home/gbsrsb5/public_html/book/common/messaging.php on line 138

Warning: fsockopen() [function.fsockopen]: unable to connect to ssl:// (Unknown error) in /home/gbsrsb5/public_html/book/common/messaging.php on line 138
Posted:  15 Mar 2017 16:22
Hi Sri,

Since I'm not familiar with PHP I'm not able to help you with that error. The information you have provided will hopefully allow Roel to provide a solution.

Kind regards,
"Little Guy"
Some own motorcycles, others ride them.

Find great LuxCal examples by Schwartz at
Posted:  17 Mar 2017 11:11
Hello Team,

Any idea on how to resolve the SMTP issue please?

Posted:  22 Mar 2017 18:29
Hi Sri,
SMTP problems are always difficult to solve from a distance; the SMTP configuration may be different for each provider. So you should check with your provider how to configure SMTP mail.
If you are sure you have the correct SMTP server name and parameters, and it still doesn't work, then I would advise you to use the smtptest.php script in the luxcal-toolbox (folder smtpmail) in the zip-file you downloaded from our site.
Upload the smtptest.php file to the calendar root, open it in your browser and follow the instructions. The document SMTP reply codes.doc contains a list of possible reply codes which may help you to analyze the problem.
Note: The smtptest.php script uses the SMTP parameters specified on the admin's Settings page of the calendar.
Posted:  14 Dec 2017 18:21
Similar problem with our live deployed version. This is the error message we get
" Warning: fsockopen(): unable to connect to ssl:// (Connection refused) in /home/ka4s9839d84g/public_html/ on line 138 "

Running the smtptest as recommended returns this "Could not connect to SMTP server 'ssl://' port '465' (111 - Connection refused)"

This does not currently help me since I have the same information on a local testing environment in our office. The SMTP information is 100% accurate since I use it in almost 200 deployed devices.

I have even added our website to the list of authorized sending servers in our email provider config. Can anyone who IS successful in sending email via SMTP chime in. We even switched over to trying to send via php email and no change.