RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / LuxCal / Known Issues and Fixes / Problem upgrading from LuxCal v4.3.0 to v4.5.0
Posted:  31 Aug 2016 10:49   Last Edited By: Roel B.
Due to a bug in the upgrade function, an SQL error will occur when upgrading from LuxCal v4.3.0 to v4.5.0. This only happens when upgrading from v4.3.0.

This problem can be fixed by editing the file common/toolboxx.php and by replacing line 517 . . .

dbQuery("INSERT INTO `categoriesNew`  SELECT * FROM `categories`"); //copy content categories table

by the following lines:

dbQuery("INSERT INTO `categoriesNew` (`ID`,`name`,`sequence`,`repeat`,`noverlap`,`olErrMsg`,`defSlot`,`approve`,`dayColor`,`color`,`bgColor`,`checkBx`,`checkLb`,`checkMk`,`status`)
SELECT `ID`,`name`,`sequence`,`repeat`,`noverlap`,`olErrMsg`,`defSlot`,`approve`,`dayColor`,`color`,`bgColor`,`checkBx`,`checkLb`,`checkMk`,`status` FROM `categories`"); //copy content categories table


Or otherwise ask us to send you an updated toolboxx.php file by email.
Roel