RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Support / HELP! - Parse Error on Install
Posted:  02 Jun 2016 17:38
I am getting the following error when I try to run the install on the lates version 4.4.0M
Parse error: syntax error, unexpected T_FUNCTION in /home/******/public_html/calendar/common/toolbox.php on line 216
Not sure what to do next
Posted:  02 Jun 2016 18:47
I know what to do next . . .
Upgrade PHP on your server to 5.3 or greater.

The current PHP version running on your server is < 5.3 and LuxCal needs 5.3 or greater.

Roel
Posted:  02 Jun 2016 19:22
PHP Version: 5.2.17

I don't suppose there is a version of LuxCal that will run on that PHP version?
Posted:  02 Jun 2016 21:27   Last Edited By: Roel B.
The latest versions all need PHP 5.3 or greater.
I could of course send you an older version from the LuxCal archive which runs on PHP 5.2, but then you would miss all these fancy new features of the latest version sad
But please note that every internet host who wants to stay in business longer than a week should upgrade PHP to 5.6 or higher. PHP 5.2 is really out of date.
Let me know if you want me to send you an "old" LuxCal version. I would hate to do this, but if you insist ohmy

Roel
Posted:  02 Jun 2016 21:39   Last Edited By: MTPockets
I didn't realize I could control the PHP version for my web site? (I know now...)
Contacted tech service for the provider and they sent me instructions.
For some reason they had it defaulting to 5.2 but you can install higher, on 5.3 now.
Everything should be good now, I'll retry the install tomorrow,
Thanks for all your help thump_up

I look forward to playing with all the new features.cool