RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Problems / Unable to send mails via smtp anymore
Posted:  02 Apr 2016 19:49   Last Edited By: Roel B.
Hi Roel

since 29.03.2016 its not possible to send mails (reminders, etc) via the smtp function. I don't know what happened because it worked perfect before. Currently I use version 440m but I have the last 2 older versions online as well and it doesn't work from the older versions as well. Well, it looks like something in my environment is wrong but i have no idea. May be you have some tips to debug.

cheers, Karl-Heinz


My evironment is an ASUSTORE NAS drive AS-302T with this software running:
Apache/2.2.31 (Unix) DAV/2 mod_mono/2.10 PHP/5.6.14 mod_ssl/2.2.31 OpenSSL/1.0.2d

smtptest.php shows the following:
C: From Client to SMTP server, S: Reply from SMTP server

C: Connect to socket (Server: ssl://smtp.googlemail.com Port: 465) (Expected reply: 220)
S: 220 smtp.googlemail.com ESMTP z127sm4759259wme.5 - gsmtp
C: EHLO ssl://smtp.googlemail.com (Expected reply: 250)
S: 501-5.5.4 HELO/EHLO argument ssl://smtp.googlemail.com invalid, closing
S: 501 5.5.4 connection. z127sm4759259wme.5 - gsmtp

EHLO: SMTP server reply: 501 5.5.4 connection. z127sm4759259wme.5 - gsmtp
Posted:  02 Apr 2016 23:17   Last Edited By: Roel B.
Hi there,

Could you disable SSL on the admin's settings page under Email Settings, and then try again.
Please let me know the outcome.

Roel
Posted:  03 Apr 2016 11:22
Hi Roel

thx for your quick reply,
Regards, Karl-Heinz

Here is the outcome:

C: From Client to SMTP server, S: Reply from SMTP server

C: Connect to socket (Server: smtp.googlemail.com Port: 465) (Expected reply: 220)

No SMTP server reply code
Posted:  11 Apr 2016 20:14
Hi

I tried to investigate the issue over the last weekend but with no luck. It looks like that my knowledge in PHP and the runtime environment (some kind of a down stripped Linux) on my NAS-Drive is to limited. I still believe the problem is caused by the runtime environment and the implementation of PHP togehter with SSL support. I found in PHP 5.6 documentation that changes were made to fsockopen especially in handling certificates. So I played around with several solutions I fond in some inet-forums regarding issues with fsockopen and SSL. But finally I implemented a circumvention by using a different SMPT server without SSL. May be with the next update of the runtime environment the problem will be solved.
Nevertheless if I find some time on the coming weekends I'll do a second try open a ticket by ASUSTOR and have a deeper look at the runtime environment.

Cheers, K-H
Posted:  13 Apr 2016 10:04
Hi K-H,

I did some testing too and have the feeling that googlemail has become more strict. Tests with googlemail that passed successfully in the past don't anymore.
There is one problem in the EHLO command sent by the calendar (argument invalid in your post above), which I fixed. But now the authentication is not accepted, I think because googlemail detects that the commands are coming from a "unknown source".

If you want to experiment, I can send you the fix for version 4.4.0, but then you should send me your mail address (via the Contact Us page).

If you find out something interesting, please keep me posted.
Cheers,
Roel
Posted:  16 Apr 2016 12:48
Hi Roel

thx for the fixes. I have tested both php scripts and they worked like a charm!smile
My calendar is now working as before with google smtp ssl settings.

Thank you very much for your effort on the LuxCal calendar.

Have a nice weekend
Cheers, Karl-Heinz
Posted:  16 Apr 2016 21:17
Great Karl-Heinz.
Thanks for letting us know!

Have a nice weekend too.
Roel