RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Problems / Not Permitted
Posted:  23 Oct 2014 17:29
When I try to open the office calendar I keep getting the following:

not permitted (index: luxcal=a:2:{i:0;N;i:1;N;})

Any ideas on how to resolve this error.
Posted:  23 Oct 2014 19:50   Last Edited By: Roel B.
Hi there,

Is this the exact error message? In particular the "index: luxcal" part as given in your post above doesn't correspond to the error messages the calendar can produce.

It looks like a message, you would get when the calendar URL would look as follows: www.yoursite.com/calendar/?luxcal[]=0&luxcal[]=1.

What LuxCal version are your using? Could you send me the URL of this calendar, so that I can further analyze the problem.
Roel
Posted:  23 Oct 2014 20:32   Last Edited By: Roel B.
Here is the URL

http://regapps.astate.edu/officecal/
Posted:  23 Oct 2014 22:01
Hi.

Welcome to LuxCal and the forum. I just visited the link to your site and it says "Please log in to view this calendar."

In the settings for user groups, for Group ID: 1 which is Read access which allows site visitors to view the calendar.

In Users for Username: Public Access for Group should be Read access. If you have set to No access than site visitors can't view calendar and must register and log in to view calendar. That means you would also have to have Self registration checked in the User Accounts section under "Settings".

Regards,
Dan
__________________
"Little Guy"
Some own motorcycles, others ride them.

Find great LuxCal examples by Schwartz at http://www.calendarforum.dk/index.html
Posted:  23 Oct 2014 22:08   Last Edited By: Roel B.
Hi Nick,

LuxCal 2.7.0b . . . that's long time ago.
The part ?cP=0&bake=1 is not part of the URL; it's added when logging in.
I can start the calendar without any problem. It however asks me to log in to view the calendar, which is correct, because apparently the public user has been given no read rights.

I've dusted the 2.7.0b LuxCal code and I got a vague memory of a similar problem in the past.
I suggest to edit the file "common/toolbox.php" as follows:
on line 148 change . . .
case 'luxcal': return preg_match('%^a:2:{.{15,60};}$%', trim($value)) ? true : false;
to . . .
case 'luxcal': return preg_match('%^a:2:{.{10,60};}$%', trim($value)) ? true : false;

("15" has been changed into "10")

This should do the trick.
Of course it would be best to upgrade to LuxCal 3.2.3 wink

Roel