RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Support / Installation: permissions
Posted:  18 Aug 2014 20:36   Last Edited By: dsmithhfx
Hi,

I'm trying to install latest release (4.10) to apache2 on ubuntu 10.04 and I'm getting the following error and success messages:

Quote:


Tests failed:
    Writing to the calendar's root folder
    Check file permissions on your server
    Writing to the 'files' folder
    Check file permissions on your server
    Writing an empty sqlite.log file to the 'logs' folder
    Check file permissions on your server
    Writing an empty luxcal.log file to the 'logs' folder
    Check file permissions on your server
Tests passed:
    PHP version 5.3.2-1ubuntu4.26 Ok
    PHP PDO-SQLite extension Ok
    PHP sessions Ok
    Form fields OK
    Writing to the database folder '../luxcal410db/'

What permissions do I need to grant (I have admin rights to the development server)?

Edit: Never mind, forgot unzips are write only. Fixed, installation worked. Thanks
Posted:  19 Aug 2014 12:28
Great!
Roel
Posted:  18 Aug 2016 20:15
I have the same test results as above with the exception of not passing the last test (writing to the database). Tell me how to fix it. Version 4.4 mysql on Turnkey linux Lamp server. Webmin  says webmin 1.760 on lamp (Debian Linux 8).
Thanks
Posted:  18 Aug 2016 22:59
More Info.
My older configuration that works shows Webmin 1.630 on lamp (Debian Linux 7). Both have MySQL ver. 5.5.50. Under the MySQL databases the one that works has a database PhpMyAdmin and the one with the permission errors does not. That is probably important.
I tried using the built in Upload and Download option two ways. One to import the zip file then open it locally. Second was to use the extract archives then delete. Third try was to use Filezilla to upload the already unzipped files. Each time in between I deleted the prior attempt.
Does anyone know what dsmithhfx meant by fixed? The ACL apparently shows permissions to be ok but I probably don't know exactly what I am looking at.
Posted:  19 Aug 2016 17:01
Hello Librarytech

The test You see above, comes from testing a SqLite installlation.

The LuxCal comes in two versions :
The M version is for a MySql installation - demands a Mysql database
And the L version is for a SqLite installation ( The SqLite is embedded in the L-package ) - database is built-in.

The easiest way to install is :
Download the package
Unzip the files locally
FTP the files to the server via Filezilla

You seem to have done this, so it should function.
Try to delete Your prior attempts and then install the L-version.
This should function.
Then  - if it functions - You know that You are able to run the calendar on Your system. ( PHP version and so )
If You want to run the MySQL version, You can delete Your installation, and try again with the M-version.
You then know that is has something with Your Mysql database to do.

Kind regards
Schwartz
Posted:  26 Aug 2016 00:04   Last Edited By: Roel B.
It took a while to get everything done. Here is what worked for me. I had been using a LAMP server setup from TurnkeyLinux. I finally started over with Debian linux and added mysql, apache2, php, myphpadmin, Webmin etc myself to build my own LAMP server. Took while to get it all working together but now it works great. Thanks to Schwartz for helping me.

Building it myself resulted in newer versions of most of the programs.
Posted:  30 Aug 2016 20:21
Hello Librarytech

In fact it was Yourself that got it to work.
It is great that You took the time, to tell what You did to get it function - this could be helpful for others that has the same problem, and search the forum for help.

kind regards
Schwartz