RSS

LuxCal Forum

The place for questions, suggestions and news about the LuxCal Event Calendar

User:   Password:   Remember Me?   
LuxCal Forum / General / Support / Can't Change settings in version 3.1.2
Posted:  20 Aug 2013 19:28
Hi Roel,

So I deleted everything (even the db) and started new with ver 3.1.2 and now I can't change settings

it keeps telling me  "missing or invalid settings (background highlighted)"  and its the calendar url that is the problem. I haven't changed the url that the install312.php setup.

Maybe it has something to do with the fact that we are using a local url for our intranet. (http://php-server/intranet/v2/calendar/)

Just though I would let you know, I am just using phpmyadmin to change setting now and that is working fine.

Travis
Posted:  20 Aug 2013 23:22   Last Edited By: Roel B.
Hi Travis,
I've sent you an email with an update to fix the calendar URL problem.
Roel
Posted:  21 Aug 2013 23:18
Thanks Roel,

I am just replying to your email.
Travis
Posted:  27 Aug 2013 16:51
Hello.
Could i have this update too ?

Same thing here, can't change settings

Thanks  :)
Posted:  27 Aug 2013 23:10
Yes, you can.
However, last Saturday my PC was damaged in a thunderstorm and currently I have no access to my send emails. I will post the fix here as soon as possible.
Roel
Posted:  02 Sep 2013 12:59
Eeek!  Though I can't pin it down to a specific cause I had a hard drive crash in my web server computer and the motherboard go belly up in my file server computer.  Both within two weeks of each other...
Posted:  04 Sep 2013 00:28   Last Edited By: Roel B.
Change this line of code on common/toolbox.php line 20

$rxCalURL = '~^(https?://)?.+\.[a-z]{2,6}(/.*)$~i'; //http://www.mysite.xxx/mycal/calendar.php

to

$rxCalURL = '~^(https?://)?[0-9a-z]([-.w]*[0-9a-z])*(:(0-9)*)*(/?)([a-z0-9-??.?,'/+&%$#_=]*)?$~i'; //http://www.mysite.xxx/mycal/calendar.php

If that doesn't work let me know.
Travis
Posted:  21 Sep 2013 15:50   Last Edited By: Roel B.
This is the original line 20 in common/toolbox.php in my luxcal312-Package:

$rxCalURL = '~^(https?://)?.+\.[a-z]{2,6}(/.*)$~i'; //http://www.mysite.xxx/mycal/calendar.php

I removed the backslash after  $rxCalURL = '~^(https?://)?.+
( see above traviss' posting ) 

$rxCalURL = '~^(https?://)?.+.[a-z]{2,6}(/.*)$~i'; //http://www.mysite.xxx/mycal/calendar.php

With this code the save settings works fine.

JonnyK
Posted:  21 Sep 2013 16:05
After submit my posting, the backslash after  $rxCalURL = '~^(https?://)?.+    is always removed, sorry. But in the original line there is a backslash.

JonnyK
Posted:  23 Sep 2013 15:11
Hi JonnyK,
Yes, the forum software doesn't like backslashes (\). I've "repaired" your previous post. The backslash is back smile
Roel